summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <[email protected]>2014-06-10 11:25:04 +0900
committerTom Stellard <[email protected]>2014-06-10 10:56:58 -0400
commit2d399bb1837e01856c8e489aa5ec439ce9a1fdbc (patch)
treea75dbe523fb4c34458dfb3feac0701825b30d228 /configure.ac
parentb0fd54900c89e2a994209d5a0007230e35dec3c6 (diff)
configure: Only check for OpenCL without LLVM when the latter is certain
LLVM is enabled by default for some architectures, but the test was failing before that. Signed-off-by: Michel Dänzer <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]> Cc: "10.1 10.2" <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1525b20f9a8..cb14c0c6623 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1462,10 +1462,6 @@ if test "x$enable_opencl" = xyes; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])
fi
- if test "x$enable_gallium_llvm" != xyes; then
- AC_MSG_ERROR([cannot enable OpenCL without LLVM])
- fi
-
if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 7; then
AC_MSG_ERROR([gcc >= 4.7 is required to build clover])
fi
@@ -1766,6 +1762,10 @@ if test "x$enable_gallium_llvm" = xyes; then
else
MESA_LLVM=0
LLVM_VERSION_INT=0
+
+ if test "x$enable_opencl" = xyes; then
+ AC_MSG_ERROR([cannot enable OpenCL without LLVM])
+ fi
fi
dnl Directory for XVMC libs