summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-10-01 16:19:43 -0400
committerTom Stellard <[email protected]>2012-10-01 17:42:56 -0400
commit00d80b3a6f0937a69d23b4956e26f3ffc924d3d6 (patch)
tree9db35673ca1590bacea78ed59a706b912617555e /configure.ac
parent67fcb3c2b4ecbd87e465b6c6b316be44811ea116 (diff)
llvmpipe: Fix build with LLVM 2.8
Commit 8d9778589f4b3a174e884338adb0fe1bdeca5eb7 added all-targets to the LLVM_COMPONENTS list, but this component does not exist with LLVM 2.8. Adding all-targets is not necessary for any drivers, and it seems to be left over from earlier versions of the commit mentioned above. Tested-by: Stéphane Marchesin <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0de506d6060..770df2f1a29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1661,7 +1661,7 @@ if test "x$enable_gallium_llvm" = xyes; then
if $LLVM_CONFIG --components | grep -q '\<mcjit\>'; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} mcjit"
fi
- LLVM_COMPONENTS="${LLVM_COMPONENTS} all-targets"
+
if test "x$enable_opencl" = xyes; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} ipo linker instrumentation"
fi