summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2017-12-03 21:58:12 +0000
committerJon Turney <[email protected]>2018-02-01 15:13:56 +0000
commitf8ed9f24d5eac1549e480dd0348d091b4299302e (patch)
treea2c4a0377ce2827997cc5b1622ba87a7c9485ec2 /configure.ac
parent7ad7a07c88b1b1c697132e8f990c0d9530fdf827 (diff)
osx: ld doesn't support --build-id
Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index daa040d3194..a54b7cb6650 100644
--- a/configure.ac
+++ b/configure.ac
@@ -686,6 +686,19 @@ LDFLAGS=$save_LDFLAGS
AM_CONDITIONAL(HAVE_LD_DYNAMIC_LIST, test "$have_ld_dynamic_list" = "yes")
dnl
+dnl OSX linker does not support build-id
+dnl
+case "$host_os" in
+darwin*)
+ LD_BUILD_ID=""
+ ;;
+*)
+ LD_BUILD_ID="-Wl,--build-id=sha1"
+ ;;
+esac
+AC_SUBST([LD_BUILD_ID])
+
+dnl
dnl compatibility symlinks
dnl
case "$host_os" in