summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Bragg <[email protected]>2012-09-19 16:12:08 +0100
committerMatt Turner <[email protected]>2012-09-24 09:49:53 -0700
commitdda49c3cb741cda2b592c5ad8e5d74edd0d7526f (patch)
tree8b5c3f9ded9cbd3aee36fcd5e004903745de757b /configure.ac
parent0f3ba405eada72e1ab4371948315b28608903927 (diff)
build: substitute X11_INCLUDES variable
There are a few automake files that reference $(X11_INCLUDES) such as src/glx/Makefile.am but configure.ac wasn't declaring the variable for substitution. This would break builds of glx if libxcb, for example, was installed in its own prefix since AM_CFLAGS wouldn't coincidentally list the needed include path in that case. Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb654675833..b83078fe371 100644
--- a/configure.ac
+++ b/configure.ac
@@ -905,6 +905,7 @@ GLESv1_CM_PC_LIB_PRIV="-lm -lpthread $DLOPEN_LIBS"
GLESv2_LIB_DEPS="$LIBDRM_LIBS -lm -lpthread $DLOPEN_LIBS"
GLESv2_PC_LIB_PRIV="-lm -lpthread $DLOPEN_LIBS"
+AC_SUBST([X11_INCLUDES])
AC_SUBST([GL_LIB_DEPS])
AC_SUBST([GL_PC_REQ_PRIV])
AC_SUBST([GL_PC_LIB_PRIV])