summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stone <[email protected]>2017-06-08 17:24:30 +0100
committerDaniel Stone <[email protected]>2018-03-09 17:47:13 +0000
commitc80c08e226033e9e33abdca43e02e7f8c845ae0a (patch)
tree055cff1a4db8f60e833f3aee9c2773429d417089 /configure.ac
parent7258be91c59b20a6479b3b0d750ff8b4a32cf032 (diff)
vulkan/wsi/x11: Add support for DRI3 v1.2
Adds support for multiple planes and buffer modifiers. v4: Rename "has_dri3_v1_1" to "has_dri3_modifiers" v12: Multi-planar/modifier support is now DRI3 v1.2; also update release versions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40e7855994a..f84903dffeb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,7 @@ WAYLAND_REQUIRED=1.11
WAYLAND_PROTOCOLS_REQUIRED=1.8
XCB_REQUIRED=1.9.3
XCBDRI2_REQUIRED=1.8
+XCBDRI3_REQUIRED=1.13
XCBGLX_REQUIRED=1.8.1
XDAMAGE_REQUIRED=1.1
XSHMFENCE_REQUIRED=1.1
@@ -1849,7 +1850,7 @@ fi
if test x"$enable_dri3" = xyes; then
DEFINES="$DEFINES -DHAVE_DRI3"
- dri3_modules="x11-xcb xcb >= $XCB_REQUIRED xcb-dri3 xcb-xfixes xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
+ dri3_modules="x11-xcb xcb >= $XCB_REQUIRED xcb-dri3 >= $XCBDRI3_REQUIRED xcb-xfixes xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
PKG_CHECK_MODULES([XCB_DRI3], [$dri3_modules])
fi