summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <[email protected]>2012-07-13 11:06:32 -0400
committerKristian Høgsberg <[email protected]>2012-07-13 11:20:17 -0400
commit426a23af147720ae3b89995ffee792a29e8ae2db (patch)
tree97e355cf0e13c53ab72ee3e0e861b7ab8465cfb9 /configure.ac
parentb3ba0a7afa6311e12852fb1373452e480f89ea96 (diff)
wayland: Stop trying to use make rules from aclocal, just copy and paste
Defeated by autotool, copy and paste to the rescue. https://bugs.freedesktop.org/show_bug.cgi?id=51997 https://bugs.freedesktop.org/show_bug.cgi?id=51531 Signed-off-by: Kristian Høgsberg <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 00a1d5d3564..0221c028d41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1728,8 +1728,9 @@ for plat in $egl_platforms; do
[AC_MSG_ERROR([cannot find libwayland-client])])
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/wayland"
- m4_ifdef([WAYLAND_SCANNER_RULES],
- [WAYLAND_SCANNER_RULES(['$(top_srcdir)/src/egl/wayland/wayland-drm/protocol'])])
+ WAYLAND_PREFIX=`$PKG_CONFIG --variable=prefix wayland-client`
+ AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner],,
+ [${WAYLAND_PREFIX}/bin$PATH_SEPARATOR$PATH])
;;
x11)