summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stone <[email protected]>2012-10-09 14:27:06 +1100
committerKenneth Graunke <[email protected]>2012-10-14 20:41:35 -0700
commit4004620d34a580c8fdb965d9b640e97453fc8b28 (patch)
treef74e612118209824acaae409dce3c9bf18dbb493 /configure.ac
parent43e6c51aed90f56e799f5cabb0b65fc352199750 (diff)
build: Don't fail if libX11 isn't installed
configure.ac would previously refuse to complete if libX11 wasn't installed, even if we'd disabled GLX and weren't building an X11 EGL platform. Make the check simply set the no_x variable that's used (but never set) immediately below for what looks like this very case. Signed-off-by: Daniel Stone <[email protected]> Reviewed-by: Matt Turner <[email protected]> Reviewed-by: Dan Nicholson <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6c7a1929eb5..aa72523c0a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -810,7 +810,7 @@ if test "x$enable_dri" = xyes; then
fi
dnl Find out if X is available.
-PKG_CHECK_MODULES([X11], [x11])
+PKG_CHECK_MODULES([X11], [x11], [no_x=no], [no_x=yes])
dnl Try to tell the user that the --x-* options are only used when
dnl pkg-config is not available. This must be right after AC_PATH_XTRA.