summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-11-06 23:18:41 -0800
committerChad Versace <[email protected]>2012-11-12 15:52:42 -0800
commit35fd61bd99c15c2e13d3945b41c4db7df6e64319 (patch)
tree23771a21726cb11bd292ba51a5e95022032c7af6 /configure.ac
parent1e8dd15311dab217d74c7c5d5a2dee6f6d7bf95e (diff)
mesa: Import a copy of the open-addressing hash table code I wrote.
Mesa's chaining hash table for object names is slow, and this should be much faster. I namespaced the functions under _mesa_*, to avoid visibility troubles that we may have had before with hash_table_* functions. v2: Move .c file to main/, const a few things, clean up loop conditions, add/extend some comments. Reviewed-by: Brian Paul <[email protected]> Reviewed-by: Chad Versace <[email protected]> Acked-by: Kenneth Graunke <[email protected]> (v1)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 558c4aa65b1..228f464c18c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2013,6 +2013,7 @@ AC_CONFIG_FILES([configs/current
src/mesa/drivers/x11/Makefile
src/mesa/libdricore/Makefile
src/mesa/main/tests/Makefile
+ src/mesa/main/tests/hash_table/Makefile
src/mesa/program/Makefile
src/mesa/x86-64/Makefile
src/mesa/x86/Makefile])