summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2012-05-29 16:03:05 -0700
committerKenneth Graunke <[email protected]>2012-05-30 13:39:30 -0700
commit2224fb6047dd96cbc11d7f2093319e5eb49c0b6b (patch)
tree2211e99d4ca3017b2bc2fccf357b470f1f1f89f4 /configure.ac
parentff3eef1affd0d3b56d4ce689947947be97c5d0f6 (diff)
automake: Check for 'indent' and fall back to 'cat' if not found.
The glapi generator code uses indent to produce more readable code. However, we don't want to make GNU indent a hard build dependency; check for it in configure.ac and fall back to 'cat' if it's not available. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=50484 Signed-off-by: Kenneth Graunke <[email protected]> Reviewed-by: Matt Turner <[email protected]> Acked-by: Ben Widawsky <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 20bd00b6751..9fb81490159 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,11 @@ AC_PROG_LEX
AC_PATH_PROG([PERL], [perl])
+AC_CHECK_PROG(INDENT, indent, indent, cat)
+if test "x$INDENT" != "xcat"; then
+ AC_SUBST(INDENT_FLAGS, '-i4 -nut -br -brs -npcs -ce -T GLubyte -T GLbyte -T Bool')
+fi
+
dnl Our fallback install-sh is a symlink to minstall. Use the existing
dnl configuration in that case.
AC_PROG_INSTALL