summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2012-12-12 14:59:36 +0000
committerChad Versace <[email protected]>2012-12-12 14:48:06 -0600
commit122345876479cf5cf553e38162ab105658614ab7 (patch)
treeb1e904b203d7d728591f1deb61f51a1417b9eb78 /configure.ac
parente721a76e6842f8aeec2c40bd9960a55f5d606f7d (diff)
configure.ac: Disable compiler optimizations when --enable-debug is set
Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Dan Nicholson <[email protected]> Reviewed-by: Chad Versace <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a133902c69f..1294740a482 100644
--- a/configure.ac
+++ b/configure.ac
@@ -341,18 +341,18 @@ AC_ARG_ENABLE([debug],
if test "x$enable_debug" = xyes; then
DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -DDEBUG"
if test "x$GCC_FOR_BUILD" = xyes; then
- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -g"
+ CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -g -O0"
fi
if test "x$GXX_FOR_BUILD" = xyes; then
- CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -g"
+ CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -g -O0"
fi
DEFINES="$DEFINES -DDEBUG"
if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -g"
+ CFLAGS="$CFLAGS -g -O0"
fi
if test "x$GXX" = xyes; then
- CXXFLAGS="$CXXFLAGS -g"
+ CXXFLAGS="$CXXFLAGS -g -O0"
fi
fi