summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2012-01-22 14:21:56 +0000
committerJon TURNEY <[email protected]>2012-01-23 18:17:48 +0000
commit0fce6d3a77f035753e2deebfc4c6bf2abe561314 (patch)
tree10a6ef5fcba2b33b841090b691a144231a646e49 /configure.ac
parentd01e16639153df9f615993c25b98d5b04fb0f0a4 (diff)
Don't build shared dricore when unneeded
Refine "always build shared dricore" so we don't build it if we don't need it because we aren't actually building any dri drivers because of --disable-driglx-direct Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9599568622a..c76af5b2401 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1060,7 +1060,7 @@ DRI_CXXFLAGS='$(CXXFLAGS)'
DRI_LIB_DEPS='$(TOP)/src/mesa/libmesa.a'
MESA_MODULES='$(TOP)/src/mesa/libmesa.a'
-if test "x$enable_dri" = xyes ; then
+if test "x$enable_dri" = xyes && test "x$driglx_direct" = xyes ; then
DRICORE_GLSL_LIBS='$(TOP)/$(LIB_DIR)/libglsl.so'
DRICORE_LIBS='$(TOP)/$(LIB_DIR)/libdricore.so'
DRICORE_LIB_DEPS='-L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -lglsl'