summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-11-19 02:39:07 +0100
committerEmil Velikov <[email protected]>2016-12-05 14:43:47 +0000
commit3f42859367cdd66b460bc8af4eab6cf9d0adc086 (patch)
tree3d769bdecd5665e9e58433504cb360c44ae1ba34 /configure.ac
parentc702369bf514cf08ec5699e5be15badb069d6e96 (diff)
configure.ac: Move radv check to the Vulkan section
This moves the LLVM check for radv to the corresponding driver section. No functional change. Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 22fcc212daa..07326e2793e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1858,6 +1858,7 @@ if test -n "$with_vulkan_drivers"; then
;;
xradeon)
PKG_CHECK_MODULES([AMDGPU], [libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
+ radeon_llvm_check "radv" "3" "9" "0"
HAVE_RADEON_VULKAN=yes;
if test "x$with_sha1" == "x"; then
AC_MSG_ERROR([radv vulkan driver requires SHA1])
@@ -2507,10 +2508,6 @@ if test -n "$with_gallium_drivers"; then
done
fi
-if test "x$HAVE_RADEON_VULKAN" = "xyes"; then
- radeon_llvm_check "radv" "3" "9" "0"
-fi
-
dnl Set LLVM_LIBS - This is done after the driver configuration so
dnl that drivers can add additional components to LLVM_COMPONENTS.
dnl Previously, gallium drivers were updating LLVM_LIBS directly