summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-11-19 02:39:03 +0100
committerEmil Velikov <[email protected]>2016-12-05 14:43:46 +0000
commit19ff3975de6947bb8c6bfddff8e599c737f9185f (patch)
treea18c784ac0315feda6bbdcb7adcdf7925680fa23 /configure.ac
parentb3119a3360824a93e193b326a57f71cda15bc96f (diff)
configure.ac: Remove swr_llvm_check()
No need for an additional function here. Use the same style for LLVM checks as the other drivers (e.g. r300, llvmpipe) that don't need a load of other checks. Instead of open conding the LLVM version check, use the function used by other drivers. "enable_gallium_llvm" is checked by gallium_require_llvm(). Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b52dc71c001..1de6b7e905d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2373,16 +2373,6 @@ radeon_gallium_llvm_check() {
radeon_llvm_check $*
}
-swr_llvm_check() {
- gallium_require_llvm $1
- if test ${LLVM_VERSION_INT} -lt 306; then
- AC_MSG_ERROR([LLVM version 3.6 or later required when building $1])
- fi
- if test "x$enable_gallium_llvm" != "xyes"; then
- AC_MSG_ERROR([--enable-gallium-llvm is required when building $1])
- fi
-}
-
swr_require_cxx_feature_flags() {
feature_name="$1"
preprocessor_test="$2"
@@ -2483,7 +2473,8 @@ if test -n "$with_gallium_drivers"; then
fi
;;
xswr)
- swr_llvm_check "swr"
+ llvm_check_version_for "3" "6" "0" "swr"
+ gallium_require_llvm "swr"
swr_require_cxx_feature_flags "C++11" "__cplusplus >= 201103L" \
",-std=c++11" \