summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-12-13 11:56:40 +0000
committerEmil Velikov <[email protected]>2018-12-13 11:56:40 +0000
commit12187550f9c248e72ed8848e96da8f29f1e3a713 (patch)
tree670b76f9d3c7c99f021bf036fa1b1060d33f4a40 /configure.ac
parentf331419f262d3a0f270376cafbb9517b4627bb7a (diff)
configure: add CXX11_CXXFLAGS to LLVM_CXXFLAGS
Seemingly with LLVM7 and GCC 5.0, the former won't properly advertise -std=c++11 and the latter will choke. dd this temporary workaround, otherwise we'll get errors like: In file included from /usr/include/c++/5/type_traits:35:0, from /usr/lib/llvm-7/include/llvm/Support/type_traits.h:18, from /usr/lib/llvm-7/include/llvm/ADT/Optional.h:22, from /usr/lib/llvm-7/include/llvm/ADT/STLExtras.h:20, from /usr/lib/llvm-7/include/llvm/ADT/StringRef.h:13, from /usr/lib/llvm-7/include/llvm/Target/TargetMachine.h:17, from ../../../src/amd/common/ac_llvm_helper.cpp:36: /usr/include/c++/5/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9b437a252cc..e4d20054d5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2903,6 +2903,7 @@ if test "x$enable_llvm" = xyes; then
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
+ LLVM_CXXFLAGS="$CXX11_CXXFLAGS $LLVM_CXXFLAGS"
dnl Set LLVM_LIBS - This is done after the driver configuration so
dnl that drivers can add additional components to LLVM_COMPONENTS.