summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2016-06-30 15:02:49 -0700
committerMatt Turner <[email protected]>2016-07-21 10:45:28 -0700
commit8c8c3f859e9eb8fde014f5837f1adb8b5481be44 (patch)
treecc012b00990854393c016893bdc9f46a8ecd8305 /configure.ac
parent5353855e9d0f470d9d4799850002a181d2b3b151 (diff)
mesa: Add -fno-math-errno -fno-trapping-math to CXXFLAGS.
Not sure why I forgot to add them to CXXFLAGS in commit f55c408067 or commit 875458b778. Cuts about 1k of .text. text data bss dec hex filename 5806354 287816 29384 6123554 5d7022 i965_dri.so before 5805497 287744 29384 6122625 5d6c81 i965_dri.so after Reviewed-by: Ian Romanick <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index accd1a15bc7..bbc3af43424 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,9 @@ if test "x$GXX" = xyes; then
# Work around aliasing bugs - developers should comment this out
CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
+
+ # We don't want floating-point math functions to set errno or trap
+ CXXFLAGS="$CXXFLAGS -fno-math-errno -fno-trapping-math"
fi
AC_SUBST([MSVC2013_COMPAT_CFLAGS])