summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVinson Lee <[email protected]>2014-05-09 18:21:59 -0700
committerVinson Lee <[email protected]>2014-05-21 16:07:00 -0700
commit8479edf3d7c693ad53f0285db03f1e2acfb777e1 (patch)
tree511d7d6649894650dee7d1518aec5c79a39ec65b /configure.ac
parenta4d229b0992806f759ab4c71fc5712e8ab2e1c9d (diff)
configure.ac: Remove -fstack-protector-strong from LLVM flags.
-fstack-protector-strong is not supported by clang. This patch fixes this build error on Fedora 20 with clang. CXX gallivm/lp_bld_debug.lo clang: error: unknown argument: '-fstack-protector-strong' Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75010 Signed-off-by: Vinson Lee <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e4d76155fb..b6e8049a405 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1591,7 +1591,8 @@ strip_unwanted_llvm_flags() {
-e 's/-fno-exceptions\>//g' \
-e 's/-fomit-frame-pointer\>//g' \
-e 's/-fvisibility-inlines-hidden\>//g' \
- -e 's/-fPIC\>//g'
+ -e 's/-fPIC\>//g' \
+ -e 's/-fstack-protector-strong\>//g'
}