summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <[email protected]>2012-02-06 17:47:48 +0800
committerMatt Turner <[email protected]>2012-02-09 10:39:50 -0500
commit50683d2aa6456f3abec8387b0b02f67ab2cab3e5 (patch)
treed89c0f51e4853494f750929713187b7736908f39 /configure.ac
parent781f84a3c2f7a06cb9e6cc44b8d5d08b39577c25 (diff)
mesa: enable remap table when --enable-shared-glapi
As libGL will use libglapi for function lookups, we need to enable the remap table. Tested-by: Brian Paul <[email protected]> Tested-by: Matt Turner <[email protected]> Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=45660
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2b1ab8f41a..846b62300a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -698,6 +698,9 @@ AC_ARG_ENABLE([shared-glapi],
SHARED_GLAPI="0"
if test "x$enable_shared_glapi" = xyes; then
SHARED_GLAPI="1"
+ # libGL will use libglapi for function lookups (IN_DRI_DRIVER means to use
+ # the remap table)
+ DEFINES="$DEFINES -DIN_DRI_DRIVER"
fi
AC_SUBST([SHARED_GLAPI])