summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Paul <[email protected]>2009-02-13 09:10:09 -0700
committerBrian Paul <[email protected]>2009-02-13 09:10:09 -0700
commitd440647eb8e65b9a199b0d98049bd1fbb85d31c7 (patch)
tree20c6f40497dd7a642f895fe88754edb0f614f59d /configure.ac
parent7e8f2c56c00f93ad55842dc5e3b123a1fcf74b3c (diff)
autoconf: Use include-fixed directory with makedepend on newer GCC
On newer GCC releases, the compiler's headers have been split between the include and include-fixed directories. Add both if the directories exist. Signed-off-by: Dan Nicholson <[email protected]> Signed-off-by: Julien Cristau <[email protected]> (cherry picked from master, commit a3d223f0d204670696338d61fe4870ff2a41f210)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 33c107266a2..ba48e9d132a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,10 +46,14 @@ esac
MKDEP_OPTIONS=-fdepend
dnl Ask gcc where it's keeping its secret headers
if test "x$GCC" = xyes; then
- GCC_INCLUDES=`$CC -print-file-name=include`
- if test "x$GCC_INCLUDES" != x; then
- MKDEP_OPTIONS="$MKDEP_OPTIONS -I$GCC_INCLUDES"
- fi
+ for dir in include include-fixed; do
+ GCC_INCLUDES=`$CC -print-file-name=$dir`
+ if test "x$GCC_INCLUDES" != x && \
+ test "$GCC_INCLUDES" != "$dir" && \
+ test -d "$GCC_INCLUDES"; then
+ MKDEP_OPTIONS="$MKDEP_OPTIONS -I$GCC_INCLUDES"
+ fi
+ done
fi
AC_SUBST([MKDEP_OPTIONS])