summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2013-09-27 16:32:40 -0700
committerEric Anholt <[email protected]>2013-10-24 14:13:09 -0700
commit86d50c2f1567eebd193ac797a49c58c969646787 (patch)
treeea4c6298494f67b5feeff2c32652c42689303753 /configure.ac
parent6665b71b22c265a318ff76178cc27732512791a8 (diff)
radeon: Build the driver into the shared mesa_dri_drivers.so.
This required some reordering of headers to ensure that the symbol name redefines happened before any prototypes. v2: drop dridir now that it's unused. v3: Consistently put spaces around += in the updated Makefile.am blocks. v4: Set a global driverAPI variable so loaders don't have to update to createNewScreen2() (though they may want to for thread safety). Reviewed-by: Matt Turner <[email protected]> (v2) Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2fcfd68faa2..0ac3bf8e172 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1039,7 +1039,7 @@ fi
enable_dricore=no
enable_megadriver=no
for driver in $DRI_DIRS; do
- if test $driver != "i965" -a $driver != "nouveau" -a $driver != "i915"; then
+ if test $driver = "swrast"; then
enable_dricore=yes
else
enable_megadriver=yes