summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <[email protected]>2012-07-17 18:30:13 +0200
committerMichel Dänzer <[email protected]>2012-07-17 19:12:01 +0200
commit761131ce4591e5f55f38d13f2c4d2194bc9cb0fd (patch)
tree890d5aefc23bc0a4864e32776c14be4d5f5bf0e9 /configure.ac
parent39c4bc7fdf2af0620c36669cca32ea332ff0c8b9 (diff)
configure.ac: Further LLVM fixups.
* Also add mcjit in the non-OpenCL case. * Replace hardcoded llvm-config with $LLVM_CONFIG everywhere. Signed-off-by: Michel Dänzer <[email protected]> Reviewed-by: Tom Stellad <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 068f632d308..1d60957af5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1847,9 +1847,9 @@ if test "x$enable_gallium_llvm" = xyes; then
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
LLVM_LIBS="-lLLVM-`$LLVM_CONFIG --version`"
else
- LLVM_LIBS="`$LLVM_CONFIG --libs engine bitwriter`"
+ LLVM_LIBS="`$LLVM_CONFIG --libs engine bitwriter mcjit`"
if test "x$enable_opencl" = xyes; then
- LLVM_LIBS="${LLVM_LIBS} `llvm-config --libs ipo linker instrumentation mcjit`"
+ LLVM_LIBS="${LLVM_LIBS} `$LLVM_CONFIG --libs ipo linker instrumentation`"
fi
fi
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
@@ -2007,7 +2007,7 @@ if test "x$with_gallium_drivers" != x; then
USE_R600_LLVM_COMPILER=yes;
fi
if test "x$enable_opencl" = xyes -a "x$with_llvm_shared_libs" = xno; then
- LLVM_LIBS="${LLVM_LIBS} `llvm-config --libs bitreader asmparser`"
+ LLVM_LIBS="${LLVM_LIBS} `$LLVM_CONFIG --libs bitreader asmparser`"
fi
gallium_check_st "radeon/drm" "dri-r600" "xorg-r600" "" "xvmc-r600" "vdpau-r600" "va-r600"
;;