summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-08-13 18:05:56 +0100
committerEmil Velikov <[email protected]>2014-08-14 15:37:33 +0100
commit395ce0b0fa0725ebfb4375beff4cdbb4df6fb4a2 (patch)
tree560edc113e28d0e499155ed53e65c24db9922004 /configure.ac
parent957a28e63c8a205d01c48cb8fa03c3c1abe4b499 (diff)
configure.ac: remove enable 32/64 bit hacks
These two were added ages ago, with an explicit comment "Hacks ..." They have been insufficient for years and maintainers needed to explicitly handle the build themselves. Rather than lying and pretending that it works, just kill this hack and let maintainers build things the way it should be done for their distribution. Document the removal in the release notes. Suggested-by: Ilia Mirkin <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 2 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index f678fa37880..dc81c807446 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,39 +243,6 @@ if test "x$SSE41_SUPPORTED" = x1; then
fi
AM_CONDITIONAL([SSE41_SUPPORTED], [test x$SSE41_SUPPORTED = x1])
-dnl
-dnl Hacks to enable 32 or 64 bit build
-dnl
-AC_ARG_ENABLE([32-bit],
- [AS_HELP_STRING([--enable-32-bit],
- [build 32-bit libraries @<:@default=auto@:>@])],
- [enable_32bit="$enableval"],
- [enable_32bit=auto]
-)
-if test "x$enable_32bit" = xyes; then
- if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -m32"
- CCASFLAGS="$CCASFLAGS -m32"
- fi
- if test "x$GXX" = xyes; then
- CXXFLAGS="$CXXFLAGS -m32"
- fi
-fi
-AC_ARG_ENABLE([64-bit],
- [AS_HELP_STRING([--enable-64-bit],
- [build 64-bit libraries @<:@default=auto@:>@])],
- [enable_64bit="$enableval"],
- [enable_64bit=auto]
-)
-if test "x$enable_64bit" = xyes; then
- if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -m64"
- fi
- if test "x$GXX" = xyes; then
- CXXFLAGS="$CXXFLAGS -m64"
- fi
-fi
-
dnl Can't have static and shared libraries, default to static if user
dnl explicitly requested. If both disabled, set to static since shared
dnl was explicitly requested.
@@ -487,10 +454,7 @@ if test "x$enable_asm" = xyes; then
case "$host_cpu" in
i?86)
case "$host_os" in
- linux* | *freebsd* | dragonfly* | *netbsd* | openbsd*)
- test "x$enable_64bit" = xyes && asm_arch=x86_64 || asm_arch=x86
- ;;
- gnu*)
+ linux* | *freebsd* | dragonfly* | *netbsd* | openbsd* | gnu*)
asm_arch=x86
;;
esac
@@ -498,7 +462,7 @@ if test "x$enable_asm" = xyes; then
x86_64|amd64)
case "$host_os" in
linux* | *freebsd* | dragonfly* | *netbsd* | openbsd*)
- test "x$enable_32bit" = xyes && asm_arch=x86 || asm_arch=x86_64
+ asm_arch=x86_64
;;
esac
;;