summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <[email protected]>2011-07-02 13:45:14 +0200
committerBenjamin Franzke <[email protected]>2011-07-02 13:56:27 +0200
commitb18b2994eff2f51588abe29c7a2209220c9ee9c5 (patch)
tree6632f91d2d15314b375a00af8cac45e766975160 /configure.ac
parentb2d6375e6a64ac12f35f8a611ebf2016e4a6dd42 (diff)
configure: Enable st/gbm if st/egl has drm platform
NOTE: This is a candidate for the 7.11 branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5a54370b51d..93b0b2684ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -597,9 +597,9 @@ AC_ARG_ENABLE([gallium_gbm],
[AS_HELP_STRING([--enable-gallium-gbm],
[enable optional gbm state tracker (not required for
gbm support in Gallium)
- @<:@default=disable@:>@])],
+ @<:@default=auto@:>@])],
[enable_gallium_gbm="$enableval"],
- [enable_gallium_gbm=no])
+ [enable_gallium_gbm=auto])
# Option for Gallium drivers
GALLIUM_DRIVERS_DEFAULT="r300,r600,swrast"
@@ -1386,6 +1386,14 @@ fi
dnl
dnl gbm Gallium configuration
dnl
+if test "x$enable_gallium_gbm" = xauto; then
+ case "$enable_gbm$HAVE_ST_EGL$with_egl_platforms" in
+ yesyes*drm*)
+ enable_gallium_gbm=yes ;;
+ *)
+ enable_gallium_gbm=no ;;
+ esac
+fi
if test "x$enable_gallium_gbm" = xyes; then
if test "x$with_gallium_drivers" = x; then
AC_MSG_ERROR([cannot enable gbm_gallium without Gallium])