summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-10 11:21:26 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:28 +0100
commitcdee0e808415214c27101103291a2be81eb02ad1 (patch)
treed2cfe9a08eb528e5908142fe9822bc82d7d203bc /configure.ac
parentd53901c67c7df914fbc5279f25d0e725c479bab0 (diff)
targets/egl-static: Convert to automake
v2: Andreas Boll <[email protected]> - Provide compatibility with scripts for the old Mesa build system - Add missing Automake.inc v3: Johannes Obermayr <[email protected]> - Fix linking. v4: Andreas Boll <[email protected]> - Port changes from ff574d653b0731a324fd30324b0f211502219abf gallium/egl-static: Fix unresolved symbol 'clock_gettime'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 81c57cf2f46..6ad1ee98790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1398,6 +1398,7 @@ if test "x$enable_openvg" = xyes; then
VG_PC_LIB_PRIV="-lm $CLOCK_LIB $PTHREAD_LIBS $DLOPEN_LIBS"
AC_SUBST([VG_PC_LIB_PRIV])
fi
+AM_CONDITIONAL(HAVE_OPENVG, test "x$enable_openvg" = xyes)
dnl
dnl D3D1X configuration
@@ -1514,8 +1515,10 @@ AC_SUBST([CLANG_RESOURCE_DIR])
case "x$enable_opengl$enable_gles1$enable_gles2" in
x*yes*)
EGL_CLIENT_APIS="$EGL_CLIENT_APIS "'$(GL_LIB)'
+ HAVE_OPENGL=yes
;;
esac
+AM_CONDITIONAL(HAVE_OPENGL, test "x$HAVE_OPENGL" = xyes)
AC_SUBST([VG_LIB_DEPS])
AC_SUBST([EGL_CLIENT_APIS])
@@ -2072,6 +2075,7 @@ AC_CONFIG_FILES([configs/current
src/gallium/targets/dri-radeonsi/Makefile
src/gallium/targets/dri-swrast/Makefile
src/gallium/targets/dri-vmwgfx/Makefile
+ src/gallium/targets/egl-static/Makefile
src/gallium/targets/opencl/Makefile
src/gallium/targets/libgl-xlib/Makefile
src/gallium/targets/vdpau-nouveau/Makefile