summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-04-04 13:02:51 -0700
committerTom Stellard <[email protected]>2013-04-15 10:54:29 -0700
commit9277b04c02de1e7a89b65839d8f4f717163ab4b1 (patch)
tree19d9fd511f8b376879a40bbb660707847979953c /configure.ac
parent7782d19cdccfd8cefebec7e665aff27463b00ec1 (diff)
radeon/llvm: Handle ELF formatted binary output from the LLVM backend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 55ebb075626..e5651329151 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1781,6 +1781,8 @@ radeon_llvm_check() {
fi
LLVM_COMPONENTS="${LLVM_COMPONENTS} r600 bitreader"
NEED_RADEON_LLVM=yes
+ AC_CHECK_LIB([elf], [elf_memory], [ELF_LIB=-lelf],
+ [AC_MSG_ERROR([radeonsi and r600g require libelf when using LLVM])])
}
dnl Gallium drivers
@@ -1999,6 +2001,7 @@ AM_CONDITIONAL(HAVE_MESA_LLVM, test x$MESA_LLVM = x1)
AM_CONDITIONAL(LLVM_NEEDS_FNORTTI, test $LLVM_VERSION_INT -ge 302)
AC_SUBST([GALLIUM_MAKE_DIRS])
+AC_SUBST([ELF_LIB])
AM_CONDITIONAL(NEED_LIBPROGRAM, test "x$with_gallium_drivers" != x -o \
"x$enable_xlib_glx" = xyes -o \