summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2010-03-02 15:34:17 -0800
committerEric Anholt <[email protected]>2010-03-03 11:33:37 -0800
commit179d2c0e0bcf96fc40107882ccab909af8c89853 (patch)
treed6f7e5dac49cf64327eabccdb37ab01b41ac09b3 /configure.ac
parent07439cf61717a3bde82745aa2acc878d7fd0133f (diff)
intel: Use drm_intel_bo_alloc_tiled for region allocs.
This moves the logic for how to align pitches, heights, and sizes of objects to one central location. Fixes rendering with texture tiling on i915. Note that current libdrm is required for the change for I915_TILING_NONE pitch alignment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d108ecdad29..e807d4acaf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -804,7 +804,7 @@ AC_SUBST([DRI_LIB_DEPS])
case $DRI_DIRS in
*i915*|*i965*)
- PKG_CHECK_MODULES([INTEL], [libdrm_intel])
+ PKG_CHECK_MODULES([INTEL], [libdrm_intel >= 2.4.19])
;;
esac