summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLauri Kasanen <[email protected]>2013-12-19 21:43:25 +0200
committerCarl Worth <[email protected]>2014-02-03 09:59:52 -0800
commit0461451dcdd640a7eda57f4211e0e03352059d3b (patch)
treed79598ac894b306f7b0238258173068ea332e43e /configure.ac
parent0657a6a6ae30aa9ba929a87a446d1628fefb4391 (diff)
mesa: Fix build to properly check for supported compiler flags
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=72708 Reviewed-by: Matt Turner <[email protected]> Signed-off-by: Lauri Kasanen <[email protected]> (cherry picked from commit fcefdc9a595c52ade2be15e0f3a2f301fee3599c)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ddbd760d4c2..f09e61cddd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,6 +228,12 @@ AC_SUBST([VISIBILITY_CFLAGS])
AC_SUBST([VISIBILITY_CXXFLAGS])
dnl
+dnl Optional flags, check for compiler support
+dnl
+AX_CHECK_COMPILE_FLAG([-msse4.1], [SSE41_SUPPORTED=1], [SSE41_SUPPORTED=0])
+AM_CONDITIONAL([SSE41_SUPPORTED], [test x$SSE41_SUPPORTED = x1])
+
+dnl
dnl Hacks to enable 32 or 64 bit build
dnl
AC_ARG_ENABLE([32-bit],