summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChad Versace <[email protected]>2018-05-31 19:57:55 -0700
committerChad Versace <[email protected]>2018-06-27 19:58:16 -0700
commitdc6665422a8fcfce92b8136310f05351aa0cbd5b (patch)
tree1466edd4efe61d3d443ca109641a600a42ef2d00 /configure.ac
parent2a5121bf355001e2c69ba05e8d9be4ed633c7bf4 (diff)
gallium: Fix automake for Android (v2)
Chromium OS uses Autotools and pkg-config when building Mesa for Android. The gallium drivers were failing to find the headers and libraries for zlib and Android's libbacktrace. v2: - Don't add a check for zlib.pc. configure.ac already checks for zlib.pc elsewhere. [for tfiga] - Check for backtrace.pc separately from the other Android libs. [for tfiga] Reviewed-by: Tomasz Figa <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 502b1787c62..f135d057365 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1836,6 +1836,9 @@ for plat in $platforms; do
android)
PKG_CHECK_MODULES([ANDROID], [cutils hardware sync])
+ if test -n "$with_gallium_drivers"; then
+ PKG_CHECK_MODULES([BACKTRACE], [backtrace])
+ fi
DEFINES="$DEFINES -DHAVE_ANDROID_PLATFORM"
;;