summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYounes Manton <[email protected]>2010-03-05 23:11:05 -0500
committerYounes Manton <[email protected]>2010-03-05 23:11:05 -0500
commit40cd082afa42c86e320f73389f3d0836587f97d9 (patch)
tree1014a6c60467d87ae25ef00345335ae620b3baf5 /configure.ac
parent4d65133e8691e51a17aa896d5bb40022cfae5a62 (diff)
vl: Add switches to autoconf.
Pass 'xorg/xvmc' to --with-state-trackers to get the XvMC state tracker. Pass --enable-gallium-g3dvl to enable the winsys.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9476a46dda..bc2d5c17012 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1241,6 +1241,22 @@ if test "x$enable_gallium_nouveau" = xyes; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nv04 nv10 nv20 nv30 nv40 nv50"
fi
+dnl
+dnl Gallium G3DVL configuration
+dnl
+AC_ARG_ENABLE([gallium-g3dvl],
+ [AS_HELP_STRING([--enable-gallium-g3dvl],
+ [build gallium g3dvl @<:@default=disabled@:>@])],
+ [enable_gallium_g3dvl="$enableval"],
+ [enable_gallium_g3dvl=no])
+if test "x$enable_gallium_g3dvl" = xyes; then
+ vl_winsys_dirs=""
+ for dir in $GALLIUM_WINSYS_DIRS; do
+ vl_winsys_dirs="$vl_winsys_dirs g3dvl/$dir"
+ done
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS $vl_winsys_dirs"
+fi
+
dnl Restore LDFLAGS and CPPFLAGS
LDFLAGS="$_SAVE_LDFLAGS"