summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorojab <[email protected]>2012-05-13 14:56:00 +0400
committerJosé Fonseca <[email protected]>2012-05-21 08:37:06 +0100
commit3d2bf91cc15885d93412a075ab575b607da55814 (patch)
tree1c452e0ea0254fcb80f2cfbb8fefccedf8f68828 /configure.ac
parentcee23ab246f22210b3063cdc47bdb45b3d943526 (diff)
Filter out -Wcovered-switch-default from LLVM_CFLAGS
Signed-off-by: José Fonseca <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 844990a2848..3bb51a2597b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1830,7 +1830,7 @@ if test "x$enable_gallium_llvm" = xyes; then
if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version | sed 's/svn.*//g'`
- LLVM_CFLAGS=`$LLVM_CONFIG --cppflags|sed -e 's/-DNDEBUG\>//g' -e 's/-pedantic//g'`
+ LLVM_CFLAGS=`$LLVM_CONFIG --cppflags|sed -e 's/-DNDEBUG\>//g' -e 's/-pedantic//g' -e 's/-Wcovered-switch-default//g'`
if test "x$with_llvm_shared_libs" = xyes; then
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
LLVM_LIBS="-lLLVM-`$LLVM_CONFIG --version`"