summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-01-14 22:21:30 -0500
committerMatt Turner <[email protected]>2012-01-20 15:54:08 -0500
commite0ee818e2f24f3d9604c04df4a056798bccc48ec (patch)
tree454307070e0e2f18f19117f0c78d05d259ebbbc0 /configure.ac
parent3c87dfce403ad3c2fed7998b16bea34dcb0c9fde (diff)
automake: src/mesa/drivers/dri/radeon
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a0ea317cb36..c0bdacbd612 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1271,8 +1271,24 @@ case $DRI_DIRS in
;;
esac
+case $DRI_DIRS in
+*radeon*)
+ PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
+
+ for d in $(echo $DRI_DIRS | sed 's/,/ /g'); do
+ case $d in
+ radeon)
+ HAVE_RADEON_DRI=yes;
+ ;;
+ esac
+ done
+
+ ;;
+esac
+
AM_CONDITIONAL(HAVE_I915_DRI, test x$HAVE_I915_DRI = xyes)
AM_CONDITIONAL(HAVE_I965_DRI, test x$HAVE_I965_DRI = xyes)
+AM_CONDITIONAL(HAVE_RADEON_DRI, test x$HAVE_RADEON_DRI = xyes)
case $DRI_DIRS in
*nouveau*)
@@ -1281,7 +1297,7 @@ case $DRI_DIRS in
esac
case $DRI_DIRS in
-*radeon*|*r200*)
+*r200*)
PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
;;
esac
@@ -1912,6 +1928,7 @@ dnl Substitute the config
AC_CONFIG_FILES([configs/autoconf
src/mesa/drivers/dri/i915/Makefile
src/mesa/drivers/dri/i965/Makefile
+ src/mesa/drivers/dri/radeon/Makefile
tests/Makefile
tests/glx/Makefile])