summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2014-05-09 13:54:09 +0100
committerJon TURNEY <[email protected]>2014-06-10 10:32:56 +0100
commitbd526ec9e1becae467fabbbe45076bb20cd12601 (patch)
tree1cecc9673ca1bd9fbb0b8edf489584feed7e39f6 /configure.ac
parentf647a722da51964412588f8ac86bab1c314448c5 (diff)
configure: Always default to --enable-driglx-direct
Always default to --enable-driglx-direct, now that will build driswrast, but won't try to use dri[123] on platforms which don't have that. Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index bb12a2a9414..1525b20f9a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -902,26 +902,12 @@ if test "x$enable_dri" = xyes; then
fi
fi
-dnl Direct rendering or just indirect rendering
-case "$host_os" in
-gnu*)
- dnl Disable by default on GNU/Hurd
- driglx_direct_default="no"
- ;;
-cygwin*)
- dnl Disable by default on cygwin
- driglx_direct_default="no"
- ;;
-*)
- driglx_direct_default="yes"
- ;;
-esac
AC_ARG_ENABLE([driglx-direct],
[AS_HELP_STRING([--disable-driglx-direct],
[disable direct rendering in GLX and EGL for DRI \
@<:@default=auto@:>@])],
[driglx_direct="$enableval"],
- [driglx_direct="$driglx_direct_default"])
+ [driglx_direct="yes"])
dnl
dnl libGL configuration per driver