summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Vetter <[email protected]>2011-11-28 22:24:26 +0100
committerDaniel Vetter <[email protected]>2011-11-28 23:54:47 +0100
commit8f15c31338e4c0e105ddc602773682375395b00b (patch)
tree22173e18a7c9756a95e9782ed2084c928eebd028 /configure.ac
parente32ada1b267c9cc84b84400a619cbca14aba2207 (diff)
gallium/i965g: hide that utterly broken driver better
And warn loudly in case people want to use it. Too many tester report gpu hangs on irc and we rootcause this ... Signed-Off-by: Daniel Vetter <[email protected]> Reviewed-by: Chad Versace <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index febb9f68098..39d4e0f552e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -658,7 +658,7 @@ GALLIUM_DRIVERS_DEFAULT="r300,r600,swrast"
AC_ARG_WITH([gallium-drivers],
[AS_HELP_STRING([--with-gallium-drivers@<:@=DIRS...@:>@],
[comma delimited Gallium drivers list, e.g.
- "i915,i965,nouveau,r300,r600,svga,swrast"
+ "i915,nouveau,r300,r600,svga,swrast"
@<:@default=r300,r600,swrast@:>@])],
[with_gallium_drivers="$withval"],
[with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT"])
@@ -2019,10 +2019,17 @@ if echo "$SRC_DIRS" | grep 'gallium' >/dev/null 2>&1; then
echo " Winsys dirs: $GALLIUM_WINSYS_DIRS"
echo " Driver dirs: $GALLIUM_DRIVERS_DIRS"
echo " Trackers dirs: $GALLIUM_STATE_TRACKERS_DIRS"
+ if echo "$GALLIUM_DRIVERS_DIRS" | grep i965 > /dev/null 2>&1; then
+ echo
+ echo " WARNING: enabling i965 gallium driver"
+ echo " the i965g driver is currently utterly broken, only for adventurous developers"
+ echo
+ fi
else
echo " Gallium: no"
fi
+
dnl Libraries
echo ""
echo " Shared libs: $enable_shared"