summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-04-20 16:56:46 +0200
committerFrancisco Jerez <[email protected]>2012-05-11 12:39:44 +0200
commit79d77b38b85aa8e906d602dd106264a8010724f1 (patch)
tree34a743d2454b3ade84aa6971ab810881edf62f96 /configure.ac
parentc6db1b3396384186aab5b685fe1fd540e17b3a62 (diff)
clover: Assorted build fixes.
Contains the following patches squashed in: commit 9fff1dc0875f7c9591550fa3ebbe1ba7a18483fa Author: Tom Stellard <[email protected]> Date: Tue Mar 20 23:20:03 2012 +0100 configure.ac: Build gallium loader when OpenCL is enabled commit 542111cb02957418c6a285cb6ef2924e49adc66e Author: Tom Stellard <[email protected]> Date: Tue Mar 20 23:30:29 2012 +0100 configure.ac: Add sw/null to GALLIUM_WINSYS_DIRS for gallium loader commit 876f8de46062dde76b6075be3b6628f969b16648 Author: Tom Stellard <[email protected]> Date: Thu Feb 9 11:26:05 2012 -0500 configure.ac: Require gcc > 4.6.0 for clover commit 99049d50fa3d9a23297ae658189c19c89dca1766 Author: Tom Stellard <[email protected]> Date: Tue Mar 20 23:32:06 2012 +0100 configure.ac: Require Gallium drm loader when gallium loader is enabled No longer silently exclude this when building OpenCL drivers for nouveau and r600.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 30 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 07ecb1f00e1..2d1265a7b63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,11 +109,11 @@ if test "x$GCC" = xyes -a "x$acv_mesa_CLANG" = xno; then
GCC_VERSION=`$CC -dumpversion`
if test $? -eq 0; then
- major=`echo $GCC_VERSION | cut -d. -f1`
- minor=`echo $GCC_VERSION | cut -d. -f2`
+ GCC_VERSION_MAJOR=`echo $GCC_VERSION | cut -d. -f1`
+ GCC_VERSION_MINOR=`echo $GCC_VERSION | cut -d. -f2`
fi
- if test $major -lt 3 -o $major -eq 3 -a $minor -lt 3 ; then
+ if test $GCC_VERSION_MAJOR -lt 3 -o $GCC_VERSION_MAJOR -eq 3 -a $GCC_VERSION_MINOR -lt 3 ; then
AC_MSG_RESULT([no])
AC_MSG_ERROR([If using GCC, version 3.3.0 or later is required.])
else
@@ -1616,8 +1616,14 @@ if test "x$enable_opencl" = xyes; then
if test "x$with_gallium_drivers" = x; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])
fi
+
+ if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 6; then
+ AC_MSG_ERROR([gcc >= 4.6 is required to build clover])
+ fi
+
GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS clover"
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS opencl"
+ enable_gallium_loader=yes
fi
dnl
@@ -1852,6 +1858,14 @@ AC_ARG_WITH([xvmc-libdir],
[XVMC_LIB_INSTALL_DIR='${libdir}'])
AC_SUBST([XVMC_LIB_INSTALL_DIR])
+dnl
+dnl Gallium Tests
+dnl
+if test "x$enable_gallium_tests" = xyes; then
+ SRC_DIRS="$SRC_DIRS gallium/tests/trivial"
+ enable_gallium_loader=yes
+fi
+
dnl Directory for VDPAU libs
AC_ARG_WITH([vdpau-libdir],
[AS_HELP_STRING([--with-vdpau-libdir=DIR],
@@ -1916,6 +1930,17 @@ gallium_require_llvm() {
fi
}
+gallium_require_drm_loader() {
+ if test "x$enable_gallium_loader" = xyes; then
+ PKG_CHECK_MODULES([LIBUDEV], [libudev], [],
+ AC_MSG_ERROR([Gallium drm loader requrires libudev]))
+ if test "x$have_libdrm" != xyes; then
+ AC_MSG_ERROR([Gallium drm loader requires libdrm >= $LIBDRM_REQUIRED])
+ fi
+ enable_gallium_drm_loader=yes
+ fi
+}
+
dnl Gallium drivers
dnl Duplicates in GALLIUM_DRIVERS_DIRS are removed by sorting it after this block
if test "x$with_gallium_drivers" != x; then
@@ -1943,6 +1968,7 @@ if test "x$with_gallium_drivers" != x; then
;;
xr600)
PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
+ gallium_require_drm_loader
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r600"
if test "x$enable_r600_llvm" = xyes; then
if test "x$LLVM_VERSION" != "x3.1"; then
@@ -1963,6 +1989,7 @@ if test "x$with_gallium_drivers" != x; then
;;
xnouveau)
PKG_CHECK_MODULES([NOUVEAU], [libdrm_nouveau >= $LIBDRM_NOUVEAU_REQUIRED])
+ gallium_require_drm_loader
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nv30 nv50 nvc0"
gallium_check_st "nouveau/drm" "dri-nouveau" "xorg-nouveau" "" "xvmc-nouveau" "vdpau-nouveau"
;;
@@ -1999,11 +2026,6 @@ if test "x$with_gallium_drivers" != x; then
done
fi
-if test "x$enable_gallium_tests" = xyes; then
- SRC_DIRS="$SRC_DIRS gallium/tests/trivial"
- enable_gallium_loader=yes
-fi
-
if test "x$enable_gallium_loader" = xyes; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/null"
GALLIUM_PIPE_LOADER_DEFINES="-DHAVE_PIPE_LOADER_SW"