summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Trippelsdorf <[email protected]>2013-12-13 10:59:42 +0100
committerBrian Paul <[email protected]>2013-12-18 07:12:13 -0700
commit78fcc31d4a8179ca24a8008a1ad1ca6bdb668fdd (patch)
tree828e82843f7376e33f94246a962972011b10c34b /configure.ac
parent00cf048b12a82f1cde066c12bea63a9f20f5f216 (diff)
configure.ac: remove -fcolor-diagnostics from LLVM flags
When LLVM is build with Clang, "llvm-config --cxxflags" contains the -fcolor-diagnostics flag. It is not recognized by gcc and the build fails. Fix by removing the flag. Signed-off-by: Markus Trippelsdorf <[email protected]> Signed-off-by: Brian Paul <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64816271e1f..b0e2b4c3844 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1546,6 +1546,7 @@ strip_unwanted_llvm_flags() {
-e 's/-O.\>//g' \
-e 's/-g\>//g' \
-e 's/-Wall\>//g' \
+ -e 's/-fcolor-diagnostics\>//g' \
-e 's/-fomit-frame-pointer\>//g'
}