summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVinson Lee <[email protected]>2014-05-21 22:13:13 -0700
committerVinson Lee <[email protected]>2014-05-21 22:13:13 -0700
commit5dd927bbfc36c8176536bb66a58467f97a1a3be3 (patch)
tree521e2337f76d9fa60b781f5111409aeaef1fdb51 /configure.ac
parentd4225f803bd01919a459cc63028deddebfb0ea2b (diff)
configure.ac: Do not enable -Wl,--no-undefined on Mac OS X.
This patch fixes this build error on Mac OS X. CCLD libglapi.la clang: warning: argument unused during compilation: '-pthread' clang: warning: argument unused during compilation: '-pthread' ld: unknown option: --no-undefined clang: error: linker command failed with exit code 1 (use -v to see invocation) Signed-off-by: Vinson Lee <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b6e8049a405..76d13337f9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -336,7 +336,7 @@ dnl OpenBSD does not have DT_NEEDED entries for libc by design
dnl so when these flags are passed to ld via libtool the checks will fail
dnl
case "$host_os" in
-openbsd*)
+openbsd* | darwin* )
LD_NO_UNDEFINED="" ;;
*)
LD_NO_UNDEFINED="-Wl,--no-undefined" ;;