summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaarten Lankhorst <[email protected]>2014-08-11 13:16:05 +0200
committerMaarten Lankhorst <[email protected]>2014-08-11 13:16:11 +0200
commit4c16e6a8e01fc8f6cbd02f2c1d367adfe17ec3c8 (patch)
tree898e5736815bdf2fff403718a7c40376467a4202 /configure.ac
parent1b417ea784b687857ab717950fd254a059f665db (diff)
configure.ac: Do not require llvm on x32
Cc: "10.2" <[email protected]> Signed-off-by: Maarten Lankhorst <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e8dd502977c..cd02babd673 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1855,6 +1855,7 @@ gallium_check_st() {
gallium_require_llvm() {
if test "x$MESA_LLVM" = x0; then
+ case "$host" in *gnux32) return;; esac
case "$host_cpu" in
i*86|x86_64|amd64) AC_MSG_ERROR([LLVM is required to build $1 on x86 and x86_64]);;
esac