summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-09-05 14:06:20 +0100
committerEmil Velikov <[email protected]>2014-09-09 19:39:36 +0100
commit40bb6f93139971a459dadf88d6dfc05791071e37 (patch)
tree7f508cd3978f3bd30c5aeef5c6dd6354f67d38ef /configure.ac
parent2220692330ab2ac2879cfa392435784f5d5c8ca2 (diff)
configure: bail out if building svga without libdrm
With recent commit we removed the NEED_NONNULL_WINSYS checks when selecting the hardware (inc svga) winsys. svga has only one winsys that explicitly requires libdrm (via it's bundled version of vmwgfx_drm.h) but configure.ac never really checks for it. Add the check early to prevent people from shooting themselves when they select the driver but lack libdrm. $ ./autogen.sh --disable-dri --disable-egl --disable-gallium-llvm --with-dri-drivers=swrast --with-gallium-drivers=svga,swrast Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=82539 Cc: "10.2 10.3" <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 176c220285a..15e0351565f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1912,6 +1912,9 @@ if test -n "$with_gallium_drivers"; then
case "x$driver" in
xsvga)
HAVE_GALLIUM_SVGA=yes
+ if test "x$have_libdrm" != xyes; then
+ AC_MSG_ERROR([Building svga requires libdrm >= $LIBDRM_REQUIRED])
+ fi
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga softpipe"
gallium_require_drm_loader
gallium_check_st "svga/drm" "dri/vmwgfx" "xa/vmwgfx"