summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2011-10-20 14:55:53 -0700
committerEric Anholt <[email protected]>2011-10-28 11:19:56 -0700
commit2f4c7ebea683de1d84501cfd11dbb963e7c027f6 (patch)
tree65858349c01bc73913455ff7bead8b51bdd71396 /configure.ac
parent9171bfe5f6549858ba952313829c50c5f905cd3d (diff)
mesa: Remove build infrastructure for r300c and r600c.
These drivers have been superseded by the gallium equivalents.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 36961452866..11d81bca28a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1185,19 +1185,19 @@ if test "x$enable_dri" = xyes; then
case "$host_cpu" in
x86_64)
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 nouveau r200 r300 r600 radeon swrast"
+ DRI_DIRS="i915 i965 nouveau r200 radeon swrast"
fi
;;
powerpc*)
# Build only the drivers for cards that exist on PowerPC.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="r200 r300 r600 radeon swrast"
+ DRI_DIRS="r200 radeon swrast"
fi
;;
sparc*)
# Build only the drivers for cards that exist on sparc
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="r200 r300 r600 radeon swrast"
+ DRI_DIRS="r200 radeon swrast"
fi
;;
esac
@@ -1207,7 +1207,7 @@ if test "x$enable_dri" = xyes; then
DEFINES="$DEFINES -DIN_DRI_DRIVER -DHAVE_ALIAS"
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 nouveau r200 r300 r600 radeon swrast"
+ DRI_DIRS="i915 i965 nouveau r200 radeon swrast"
fi
;;
gnu*)
@@ -1227,7 +1227,7 @@ if test "x$enable_dri" = xyes; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 nouveau r200 r300 r600 radeon swrast"
+ DRI_DIRS="i915 i965 nouveau r200 radeon swrast"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
@@ -1276,7 +1276,7 @@ case $DRI_DIRS in
esac
case $DRI_DIRS in
-*radeon*|*r200*|*r300*|*r600*)
+*radeon*|*r200*)
PKG_CHECK_MODULES([LIBDRM_RADEON],
[libdrm_radeon >= $LIBDRM_RADEON_REQUIRED],
HAVE_LIBDRM_RADEON=yes,