summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2014-09-09 07:04:20 -0400
committerTom Stellard <[email protected]>2014-09-09 09:47:25 -0400
commit181581280bd430d122d416e308c1de82db82da04 (patch)
tree6b56ba0f410dbc8b7efaa7ea53d9a01901deda1a /configure.ac
parent78c9201a5b57ed635b7161fd638cf6814e103e1b (diff)
configure.ac: Fix build with git-svn llvm version string
Reviewed-and-tested-by: Jan Vesely <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index be85fd51bc8..176c220285a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1687,7 +1687,7 @@ if test "x$enable_gallium_llvm" = xyes; then
fi
if test "x$LLVM_CONFIG" != xno; then
- LLVM_VERSION=`$LLVM_CONFIG --version | sed 's/svn.*//g'`
+ LLVM_VERSION=`$LLVM_CONFIG --version | grep -o '^[[0-9.]]\+'`
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_BINDIR=`$LLVM_CONFIG --bindir`
LLVM_CPPFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cppflags"`