aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d396e547..3a8ae9b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,11 +204,13 @@ else()
endif()
unset(OLD_REQUIRED_LIBRARIES)
-# Include liblog for Android logging
-check_library_exists(log __android_log_print "" HAVE_LIBLOG)
-if(HAVE_LIBLOG)
- set(EXTRA_LIBS log ${EXTRA_LIBS})
- set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} log)
+if(ANDROID)
+ # Include liblog for Android logging
+ check_library_exists(log __android_log_print "" HAVE_LIBLOG)
+ if(HAVE_LIBLOG)
+ set(EXTRA_LIBS log ${EXTRA_LIBS})
+ set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} log)
+ endif()
endif()
if(MSVC)