aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-09-11 06:47:56 -0700
committerChris Robinson <[email protected]>2019-09-11 06:47:56 -0700
commitbe0442c6207cc10fca079a803bbdd8985959b657 (patch)
treef454f679117428575d639e5b386104495889fe85 /CMakeLists.txt
parent388928f3aa1ecf1a4f930c27687e7d0d4a9fd824 (diff)
Avoid C-style casts in C++
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7626c1ef..c37a2d18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,7 +220,7 @@ IF(MSVC)
ENDFOREACH(flag_var)
ENDIF()
ELSE()
- SET(C_FLAGS ${C_FLAGS} -Winline -Wall)
+ SET(C_FLAGS ${C_FLAGS} -Winline -Wall -Wold-style-cast)
CHECK_C_COMPILER_FLAG(-Wextra HAVE_W_EXTRA)
IF(HAVE_W_EXTRA)
SET(C_FLAGS ${C_FLAGS} -Wextra)