aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2020-03-21 08:39:45 -0700
committerChris Robinson <[email protected]>2020-03-21 08:39:45 -0700
commitadf28d87aac0be1f21a38e5c5e720cae281989ce (patch)
treede2fcf62776b983215bd24233d5db8d186a4398d /CMakeLists.txt
parent12775513ae666b0433e63b82b80de87019770b35 (diff)
Remove the check for stat()
It's POSIX-2001 standard
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 599273a5..592a7687 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -447,8 +447,6 @@ CHECK_SYMBOL_EXISTS(posix_memalign stdlib.h HAVE_POSIX_MEMALIGN)
CHECK_SYMBOL_EXISTS(_aligned_malloc malloc.h HAVE__ALIGNED_MALLOC)
CHECK_SYMBOL_EXISTS(proc_pidpath libproc.h HAVE_PROC_PIDPATH)
-CHECK_FUNCTION_EXISTS(stat HAVE_STAT)
-
IF(NOT WIN32)
# We need pthreads outside of Windows, for semaphores. It's also used to
# set the priority and name of threads, when possible.