aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-09-18 10:09:04 -0700
committerChris Robinson <[email protected]>2019-09-18 10:09:04 -0700
commit66565ca7a3cd63e242eedb0141341eb9450f0d4a (patch)
tree09ef30049942305dec9241fe896b8fad7685da11 /CMakeLists.txt
parentda80a7c2b2e4a66856bec4d7b44c7a7df05a31a5 (diff)
Enable and fix some more warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ef1ca6b..4f6cf010 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -222,6 +222,7 @@ IF(MSVC)
ENDIF()
ELSE()
SET(C_FLAGS ${C_FLAGS} -Winline -Wunused -Wall -Wextra -Wshadow -Wconversion -Wcast-align
+ -Wpedantic -Wno-zero-length-array
$<$<COMPILE_LANGUAGE:CXX>:-Wold-style-cast -Wnon-virtual-dtor -Woverloaded-virtual>)
IF(ALSOFT_WERROR)