aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-09-16 18:10:01 -0700
committerChris Robinson <[email protected]>2019-09-16 18:10:01 -0700
commit62972babea90f8f0444d4dbaaabe9e017cc0abfb (patch)
treea08d3638c414bc4ba9817ba10f26d0ac3140ffa4 /CMakeLists.txt
parent6398bd83739a3cb3ae38078f4221c5ab28057824 (diff)
Remove unnecessary long long checks
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d467287a..d054cb84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,7 +114,6 @@ SET(EXPORT_DECL "")
CHECK_TYPE_SIZE("long" SIZEOF_LONG)
-CHECK_TYPE_SIZE("long long" SIZEOF_LONG_LONG)
# Require C++11
@@ -553,13 +552,6 @@ ENDIF()
CHECK_SYMBOL_EXISTS(getopt unistd.h HAVE_GETOPT)
-# Check for a 64-bit type
-IF(NOT SIZEOF_LONG MATCHES "8")
- IF(NOT SIZEOF_LONG_LONG MATCHES "8")
- MESSAGE(FATAL_ERROR "No 64-bit type found, please report!")
- ENDIF()
-ENDIF()
-
# Common sources used by both the OpenAL implementation library and potentially
# the OpenAL router.