aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2020-10-13 05:59:35 -0700
committerChris Robinson <[email protected]>2020-10-13 05:59:35 -0700
commit5f8fe0e5bb67a52f14dec50e8517a126c059aaf7 (patch)
tree24e8cec7454508ae61c65db0d8c188c71cb170a8 /CMakeLists.txt
parent7b43cb8266056f1c28c1556c123fed238ec3210f (diff)
Enable standard stdio methods with MinGW
This unfortunately doesn't fix the %z warnings for whatever reason, but it should help guarantee correct function behavior by not relying on msvcrt's stdio functions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d09547c..e7f82dc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,6 +116,9 @@ set(EXTRA_LIBS )
if(WIN32)
set(CPP_DEFS ${CPP_DEFS} _WIN32)
+ if(MINGW)
+ set(CPP_DEFS ${CPP_DEFS} __USE_MINGW_ANSI_STDIO)
+ endif()
option(ALSOFT_BUILD_ROUTER "Build the router (EXPERIMENTAL; creates OpenAL32.dll and soft_oal.dll)" OFF)
if(MINGW)