aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-03-24 17:31:10 -0700
committerChris Robinson <[email protected]>2019-03-24 17:31:10 -0700
commit7c16b1e02f5f8888741b7ee4a737506ac8ff5321 (patch)
tree1e717e0939f6483b6b1a213165d81ceb4f047352 /CMakeLists.txt
parentc8e8ac42abb9225c3abfac036340548cfaaa0e92 (diff)
Rename makehrtf to makemhr and move it to a subdirectory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 12 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60e3bbd2..ff35317d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1457,15 +1457,20 @@ IF(ALSOFT_UTILS)
find_package(MySOFA)
if(MYSOFA_FOUND)
- set(MAKEHRTF_SRCS utils/makehrtf.cpp)
+ set(MAKEMHR_SRCS
+ utils/makemhr/loaddef.cpp
+ utils/makemhr/loaddef.h
+ utils/makemhr/loadsofa.cpp
+ utils/makemhr/loadsofa.h
+ utils/makemhr/makemhr.cpp)
if(NOT HAVE_GETOPT)
- set(MAKEHRTF_SRCS ${MAKEHRTF_SRCS} utils/getopt.c utils/getopt.h)
+ set(MAKEMHR_SRCS ${MAKEMHR_SRCS} utils/getopt.c utils/getopt.h)
endif()
- add_executable(makehrtf ${MAKEHRTF_SRCS})
- target_compile_definitions(makehrtf PRIVATE ${CPP_DEFS})
- target_compile_options(makehrtf PRIVATE ${C_FLAGS})
- target_link_libraries(makehrtf PRIVATE ${LINKER_FLAGS} MySOFA::MySOFA)
- set(UTIL_TARGETS ${UTIL_TARGETS} makehrtf)
+ add_executable(makemhr ${MAKEMHR_SRCS})
+ target_compile_definitions(makemhr PRIVATE ${CPP_DEFS})
+ target_compile_options(makemhr PRIVATE ${C_FLAGS})
+ target_link_libraries(makemhr PRIVATE ${LINKER_FLAGS} MySOFA::MySOFA)
+ set(UTIL_TARGETS ${UTIL_TARGETS} makemhr)
set(SOFAINFO_SRCS utils/sofa-info.cpp)
add_executable(sofa-info ${SOFAINFO_SRCS})