aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-01-09 06:40:50 -0800
committerChris Robinson <[email protected]>2010-01-09 06:40:50 -0800
commitef7df2416debb882c42124bddc07808c00a4503b (patch)
tree20e2e8a67a0a3bb8d8175994b4f006c6fcc456cd /CMakeLists.txt
parentcb113315f7cacfef0ca1f7a08d714344a89447da (diff)
Hide OSS and Solaris devices if their files can't be stat'd
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 317a5129..8c60a11e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -152,6 +152,7 @@ ENDIF()
CHECK_FUNCTION_EXISTS(strtof HAVE_STRTOF)
CHECK_FUNCTION_EXISTS(_controlfp HAVE__CONTROLFP)
+CHECK_FUNCTION_EXISTS(stat HAVE_STAT)
CHECK_FUNCTION_EXISTS(strcasecmp HAVE_STRCASECMP)
IF(NOT HAVE_STRCASECMP)
CHECK_FUNCTION_EXISTS(_stricmp HAVE__STRICMP)