aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-03-23 18:21:55 -0700
committerChris Robinson <[email protected]>2010-03-23 18:21:55 -0700
commit7fb4c4ce4fca4c7849f911c3a8dc7643167a1c7d (patch)
tree2fc030201738114b63361674f930db10c754afbe /CMakeLists.txt
parent52834744fa4236717e45d9be588c4b4e26f562cc (diff)
Move extension function declarations to alext.h/efx.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index decc2542..49b3a1ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -443,6 +443,7 @@ IF(NOT LIBTYPE)
ENDIF()
ADD_LIBRARY(${LIBNAME} ${LIBTYPE} ${OPENAL_OBJS} ${ALC_OBJS})
SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES DEFINE_SYMBOL AL_BUILD_LIBRARY
+ COMPILE_FLAGS -DAL_ALEXT_PROTOTYPES
VERSION ${LIB_VERSION}
SOVERSION ${LIB_MAJOR_VERSION})
IF(WIN32)