aboutsummaryrefslogtreecommitdiffstats
path: root/java/CMakeLists.txt
diff options
context:
space:
mode:
authorPetre Eftime <[email protected]>2016-05-23 17:42:28 +0300
committerPetre Eftime <[email protected]>2016-05-23 18:17:45 +0300
commitf475d6dbcc549022920090ac11d783f011ffc010 (patch)
treef32e3139295fe4d0e7031c1b106f8eac12e1b4ea /java/CMakeLists.txt
parentb98d8d7ad75d748596ee0246b6f21a74f4b61ef3 (diff)
c++, java: Add BluetoothException, throw it on DBus or BlueZ error
Signed-off-by: Petre Eftime <[email protected]>
Diffstat (limited to 'java/CMakeLists.txt')
-rw-r--r--java/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/java/CMakeLists.txt b/java/CMakeLists.txt
index 6288cf59..33581bcf 100644
--- a/java/CMakeLists.txt
+++ b/java/CMakeLists.txt
@@ -33,6 +33,7 @@ set(JAVA_CLASSES tinyb.BluetoothAdapter
tinyb.BluetoothManager
tinyb.BluetoothObject
tinyb.BluetoothType
+ tinyb.BluetoothException
tinyb.ObjectArgCallback
tinyb.ObjectArrayArgCallback)
add_custom_command (TARGET tinybjar