aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-08-25 05:22:57 +0200
committerSven Gothel <[email protected]>2020-08-25 05:22:57 +0200
commitd3fcf4948480b9ab7f426cf54475e54aee1ce79b (patch)
tree2229f0d762b0582ae15ffd5d8746f507ea8d03a7 /CMakeLists.txt
parent2d6c05f88c379f9091d291aad90fc03e4ea10b33 (diff)
cmake: Add variable/define 'SKIP_TINYB': Allow to not build the tinyb native library.
Building the native lib on slow systems becomes a burden, hence skip if not required.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4777412..776b18f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,10 +96,12 @@ ENDIF(DEBUG)
find_path (SYSTEM_USR_DIR "stdlib.h")
include_directories (${SYSTEM_USR_DIR})
-add_subdirectory (src/tinyb)
-
add_subdirectory (src/direct_bt)
+if(NOT SKIP_TINYB)
+ add_subdirectory (src/tinyb)
+endif()
+
option (BUILDJAVA "Build Java API." OFF)
IF(BUILDJAVA)